Intereting Posts
nslayoutconstraint анимации разные задержки dateFromString, работающий в ios 6, но не в ios 5 Swift, как перемещать метку tableView backGroundView iOS – Не удалось загрузить NIB в комплекте Уведомление, когда AVQueuePlayer перематывает назад к началу элемента Ошибка компиляции для модели данных на пути – xcode 6 Внедрение NSOperationQueue путем отправки запроса и сохранения ответа в базе данных параллельно undefined символы для архитектуры armv7s Представляя подсказку Touch ID, можно ли сразу предложить пользователю возможность ввести свой пароль? Как открыть приложение с устройства iOS при щелчке ссылки, разделяемой с веб-приложением? Safari iOS | 100% – слишком высокая страница для просмотра Swift: Справка по расширениям Почему цвет «цвет оттенка» не соответствует цвету? Информация о документе UIGraphics.BeginPDFContext Как создать непрерывную анимацию с изображением в iOS

Проблема установки приложения Apple Watch – NSExtensionPointIdentifier

Я пытаюсь установить приложение с WatchKit App и WatchKit Extension на iOS8.1-телефон с Xcode 6.2.

У меня установлен параметр развертывания 8.1, а базовый SDK – 8.2.

Я получаю эту ошибку:

This app contains an app extension that specifies an extension point identifier that is not supported on this version of iOS for the value of the NSExtensionPointIdentifier key in its Info.plist 

Я видел некоторые подобные вопросы, но не нашел решение, которое работает. Есть ли способ программно обрабатывать более низкую версию iOS?

Чтобы ответить на этот вопрос (используя комментарий @ LoVo), я исправил проблему, изменив цель развертывания на 8.2 в настройках сборки расширения (не в настройках сборки основного приложения).

Цель развертывания основного приложения может быть установлена ​​с более низкой целью развертывания, сейчас мой 7,0.