Articles of cocoapods

Почему мой код проекта не может получить доступ к моим CocoaPods?

Я использую CocoaPods для добавления SnapKit в мой проект iOS. Однако ни одна из функций SnapKit не доступна из моего исходного кода. Xcode немедленно выдает предупреждение компилятора по этим строкам «этого не существует» Я выполнил инструкции по установке, перечисленные здесь . Я также открыл CocoaPods созданный CocoaPods и я вижу проект приложения и проект Pods […]

Bridging-header работает, но импорт не работает?

Я установил библиотеку с помощью CocoaPods, и все это работает. Я добавил в свой проект мостовой заголовок, который, как я знаю, работает, поскольку я использую несколько разных библиотек в этом заголовке. Но я только что установил и подключил libPhoneNumber-iOS, и, похоже, он работает, за исключением … это не так. Я нахожу файлы, они импортируют их […]

Как сделать установку Cocoapods?

Я хочу сделать установку Cocoapods, но я не знаю, как это сделать? Какую версию мне нужно скачать согласно версии Xcode? Какую настройку настройки мне нужно сделать? И, наконец, как сделать установку pod например, Добавить pod 'Parse' в ваш podfile и запустить pod install.

Как проверить во время компиляции, если в текущем проекте существует модуль Swift?

Я хотел бы знать, есть ли в Swift какая-либо команда препроцессора, чтобы проверить, существует ли модуль. Я использую инструмент менеджера зависимостей CocoaPods, и я бы хотел проверить во время компиляции, чтобы я мог использовать его, или мне нужно сделать обычное обходное решение. Это было бы примерно так: #if module(SwiftyJSON) #else #endif

Интеграция awsmobilehub и cocoapods

Я начал использовать AWSMobileHub, и я просто перехожу к шагам интеграции, но, похоже, он не играет хорошо с cocoapods, которые я намереваюсь использовать в проекте. Я выполнил шаги интеграции и добавил фреймворки, которые я загрузил из aws + вспомогательного кода. Я добавил их в качестве встроенных фреймворков Это компилируется и работает отлично Затем я добавляю […]

Не удается установить Cocoapods в приложение при вводе «pod install» (ОШИБКА: Не удалось создать собственное расширение gem.)

Я использую OSX Yoemite, и я посетил почти все вопросы об этом в StackOverflow, и ни один из ответов не работал … В настоящее время я пытаюсь использовать команду «pod install», и я получаю эту ошибку: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:245:in `mkdir': Permission denied – /Library/Ruby/Gems/2.0.0/extensions/universal-darwin-14/2.0.0/xcodeproj-0.16.1 (Errno::EACCES) from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:245:in `fu_mkdir' from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:219:in `block (2 levels) in mkdir_p' from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/fileutils.rb:217:in […]

Невозможно установить SDWebImage с помощью CocoaPods: «ld: библиотека не найдена для -lSDWebImage»

Я пытаюсь импортировать SDWebImage в свой проект iOS, используя Cocoapods. Поэтому я установил Cocoapods и создал этот Podfile в моей директории проектов: platform :ios, '7.0' target 'MyProjectV6' do pod 'SDWebImage', '~>3.7' end Затем я запускаю его с помощью команды pod install , и все выглядит нормально: Analyzing dependencies Downloading dependencies Installing SDWebImage 3.7.5 (was 3.7.5) […]

Проблема с комплектом Crashlytics and Answers

Я использую Crashlytics в своем приложении для отслеживания сбоев и наборов ответов тоже для пользовательских событий. Я интегрирую фреймворки в свой проект, используя pod-файл. Но я получаю ошибку связывания, в то время как оба контейнера добавляются как pod 'Fabric' pod 'Answers' pod 'Crashlytics' Когда я удаляю один из ответов и Crashlytics, тогда все в порядке. […]

как запустить pod install в каталоге проекта

В учебном пособии мне предлагается запустить pod install в каталоге проекта. Может ли кто-нибудь сказать мне, как это сделать?

XCode7: библиотека не найдена для -lAFNetworking

У меня возникла проблема, когда я пытаюсь скомпилировать приложение iOS с pod AFNetworking (установлено командой «pod install»). XCode показывает эту ошибку: ld: library not found for -lAFNetworking и это деталь Ld /Users/MYUSER/Library/Developer/Xcode/DerivedData/MYAPP-amzbjdohegzauqguojdhppmipzoh/Build/Products/Debug-iphonesimulator/MYAPPEnterprise.app/MYAPPEnterprise normal i386 cd "/Users/MYUSER/MYAPP/MYAPP" export IPHONEOS_DEPLOYMENT_TARGET=7.0 export PATH="/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin" /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -arch i386 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator9.2.sdk -L/Users/MYUSER/Library/Developer/Xcode/DerivedData/MYAPP-amzbjdohegzauqguojdhppmipzoh/Build/Products/Debug-iphonesimulator -L/Users/MYUSER/MYAPP/MYAPP/Libraries/libSMPPayment/Current/Libraries -L/Users/MYUSER/MYAPP/MYAPP/Libraries/libSMPPayment/6.0/Libraries -F/Users/MYUSER/Library/Developer/Xcode/DerivedData/MYAPP-amzbjdohegzauqguojdhppmipzoh/Build/Products/Debug-iphonesimulator -F. -FClasses -FLibraries -FPods -FResources -FSettings.bundle […]