Будет ли тот же IOS SDK иметь разные типы поведения, используя разные версии Xcode

Сначала мой первый вопрос был: смогу ли я загрузить AppStore с помощью старого SDK. Глядя на Apple Documentation и вопрос переполнения стека, я пришел к выводу, что я могу загрузить свое приложение с использованием старого SDK, если он находится в разумном количестве времени с момента выпуска нового SDK. Однако я не смог найти минимально необходимый SDK. В этот момент в моих исследованиях я думаю, что я могу использовать старый SDK для подачи заявки. Неужели я ошибаюсь? Как долго я должен ожидать, что текущий Xcode 7 SDK будет поддерживаться?

(Я знаю, мы должны как можно скорее перейти к последнему SDK.)

Моя компания работает над несколькими проектами iOS, и у нас скоро будет большой патч для одного из них (может быть, в декабре). Мы не хотим вводить новые ошибки . Мы понимаем, что мы должны изменить SDK, но на данный момент времени это будет слишком много времени. Некоторым из нас хотелось бы воспользоваться последней версией Xcode для некоторых родных проектов, что подводит меня к моему второму вопросу. Прямо сейчас, если у нас есть приложение с ошибкой, использующее Xcode X (7), можно ли ожидать такого же безошибочного приложения, используя Xcode X + 1 (8) с тем же SDK. Это безопасно или мы будем рисковать?

Давайте будем гением компьютера.